<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Jackson trustees approve developer's site changes</title><meta property=og:title content="Jackson trustees approve developer's site changes"/><link rel=amphtml href=https://amp.thesuburbanite.com/amp/7445579002 /><meta property=article:author content="Patricia Faulhaber"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.thesuburbanite.com /><link rel=preconnect href=https://user.thesuburbanite.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=preconnect href=https://cdn.tinypass.com /><link rel=dns-prefetch href=//cdn.tinypass.com /><link rel=preconnect href=https://experience.tinypass.com crossorigin/><link rel=dns-prefetch href=//experience.tinypass.com /><link rel=preconnect href=https://buy.tinypass.com /><link rel=dns-prefetch href=//buy.tinypass.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.thesuburbanite.com/NSUB-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z343c41a59.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=https://cdn.tinypass.com/api/tinypass.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-0be9f6c1.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/03956b05-028b-47f5-a1b1-cf0ceae5bdc3/37edafaf-c891-4b9e-9c68-f4a2e0770842/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=5240744001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="Approval came following public hearing where the developer talked discussed the housing plan"/><meta property=og:description content="Approval came following public hearing where the developer talked discussed the housing plan"/><meta property=fb:pages content=469544275013 /><meta property=fb:app_id content=1010995929332131 /><link rel=canonical href=https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/ /><meta property=og:url content=https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/ /><meta property=og:site_name content="The Suburbanite"/><meta property=og:image content=https://www.thesuburbanite.com/tangstatic/sites/nsub/og-image-q1a2z3b4b0ab9f.png /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:site content=@SuburbaniteGHO /><meta name=twitter:creator content=@SuburbaniteGHO /><meta name=twitter:title content="Jackson trustees approve developer's site changes"/><meta name=twitter:description content="Approval came following public hearing where the developer talked discussed the housing plan"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="The Suburbanite" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.64 51.64"><path d="M6.09 21.89h.95v5.91h3.78v3.52h-3.8v13.1c0 1.97.21 3.1 1.6 3.1a5.07 5.07 0 002.18-.62v3.57c-1.6.67-2.48.88-3.57.88-2.75 0-4.25-1.5-4.25-5.13v-14.9H.08v-.95l6.01-8.48zm20.2 12.38v16.47h-4.04V34.38c0-1.97-.48-3.37-2.18-3.37-1.19 0-2.23.88-3.16 2.75v16.99h-4.04v-34.6h4.04v14.14h.1c1.24-2.02 2.43-2.86 4.25-2.86 2.9.01 5.03 2.34 5.03 6.84zm15.37 4.87v1.03h-8.5c0 4.87 1.43 7.46 4.09 7.46 1.5 0 2.79-.78 3.94-2.28v3.99c-1.5 1.4-3 2.02-4.71 2.02-4.56 0-7.37-4.04-7.37-12.12 0-7.62 2.33-12.07 6.37-12.07 5.61.01 6.18 7.77 6.18 11.97zm-4.04-1.97c0-4.25-.68-6.47-2.33-6.47-1.55 0-2.18 2.38-2.18 6.22v.26h4.51zm19.12 12.29V42.8c1.8 1.72 3.75 2.77 5.62 2.77a4.86 4.86 0 004.87-4.84v-.03c0-3.9-2.86-8.84-5.62-14.09-2.62-4.95-5.17-10.27-5.17-15.14C56.45 4.57 60.79 0 66.64 0c1.88 0 3.23.38 5.4 1.35v6.07c-2.17-1.28-3.15-1.58-4.5-1.58-3.15 0-4.87 1.58-4.87 4.8 0 3.9 2.47 8.32 5.1 13.12 2.77 5.17 5.71 10.64 5.71 16.12 0 6.82-4.19 11.54-10.34 11.54-2.5-.02-4.3-.68-6.4-1.96zm26.15-31.92v23.68c0 2.86.68 4.87 3.15 4.87 1.72 0 3.22-1.28 4.57-3.97V17.54h5.85v33.2H90.6v-3.6h-.15c-1.8 2.92-3.52 4.12-6.15 4.12-4.19 0-7.27-3.37-7.27-9.89V17.54h5.86zm27.55 33.72a26.1 26.1 0 01-8.77-1.8V.68h5.84v18.59h.13c1.12-1.72 2.47-2.62 5.02-2.62 4.57 0 9.52 4.72 9.52 17.16.02 12.36-4.78 17.45-11.74 17.45zm-2.93-5.84c.93.38 1.92.58 2.93.6 4.05 0 5.77-4.35 5.77-12.29 0-7.34-1.88-11.54-5.1-11.54-1.65 0-2.77 1.12-3.6 2.77v20.46zm24.55-27.88v23.68c0 2.86.68 4.87 3.15 4.87 1.73 0 3.22-1.28 4.57-3.97V17.54h5.84v33.2h-5.84v-3.6h-.15c-1.79 2.92-3.52 4.12-6.14 4.12-4.2 0-7.27-3.37-7.27-9.89V17.54h5.84zm33.47 6.44a4.24 4.24 0 00-2.55-.82c-4.42 0-5.77 8.47-6.3 14.46v13.12h-5.84v-33.2h5.84v8.24h.15c1.95-6.66 3.3-8.77 6.14-8.77 1.07 0 2.12.33 3 .95l-.44 6.02zm11.99 27.28a26.1 26.1 0 01-8.77-1.8V.68h5.85v18.59h.15c1.12-1.72 2.47-2.62 5.02-2.62 4.57 0 9.52 4.72 9.52 17.16 0 12.36-4.8 17.45-11.77 17.45zm-2.92-5.84c.93.38 1.92.58 2.92.6 4.05 0 5.77-4.35 5.77-12.29 0-7.34-1.87-11.54-5.1-11.54-1.65 0-2.77 1.12-3.59 2.77v20.46zm36.05-19.86v18.81c0 1.43.3 1.87.9 1.87.3 0 1.05-.45 2.32-1.65v4.43c-1.8 1.8-3.22 2.47-4.57 2.47-1.87 0-3.81-.83-4.28-4.2-1.95 3.22-4.2 4.35-6.37 4.35-4.57 0-6.52-4.2-6.52-8.4 0-3.9 1.65-6.37 6.3-9.59a98.28 98.28 0 016.37-3.97v-3.15c0-2.93-1.12-4.35-3.45-4.35-2.47 0-4.87 1.5-8.4 5.47v-6.74c3.53-3.23 5.62-4.28 8.85-4.28 5.18.03 8.85 2.71 8.85 8.93zm-9.89 20.53c1.58 0 3.07-1.5 4.05-3.81v-8.57c-4.65 2.86-6.89 5.55-6.89 8.62-.01 2.19 1.1 3.76 2.84 3.76zm35.6-19.18v23.84h-5.84V27.06c0-2.86-.68-4.87-3.15-4.87-1.72 0-3.22 1.28-4.57 3.97v24.58h-5.84v-33.2h5.87v3.6h.15c1.8-2.92 3.52-4.12 6.14-4.12 4.17-.01 7.24 3.36 7.24 9.89zm11.36-23.54a3.37 3.37 0 110-.02v.02zm-.46 14.17v33.2h-5.84v-33.2h5.84zM258.92 9h1.35v8.57h5.47v5.07h-5.47V41.6c0 2.86.3 4.5 2.32 4.5.9 0 1.65-.23 3.15-.9v5.17c-2.32.98-3.6 1.28-5.17 1.28-3.97 0-6.14-2.18-6.14-7.42V22.64h-4.2v-1.35L258.92 9zm26.72 24.95v1.5h-12.29c0 7.04 2.1 10.79 5.93 10.79 2.17 0 4.05-1.12 5.71-3.3v5.77c-2.17 2.02-4.35 2.92-6.82 2.92-6.6 0-10.64-5.84-10.64-17.54-.02-11.02 3.36-17.44 9.2-17.44 8.09.01 8.91 11.23 8.91 17.3zm-5.84-2.85c0-6.14-.98-9.37-3.37-9.37-2.25 0-3.15 3.45-3.15 8.99v.38h6.52z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.thesuburbanite.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021MEMDAY&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.thesuburbanite.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021MEMDAY&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce gnt_n_mn_l__se" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.publicnoticesohio.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Canton" title="Weather in Canton" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.thesuburbanite.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021MEMDAY&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.thesuburbanite.com/NSUB-GUP/authenticate?success-url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F&cancel-url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-oh-canton-weekly-C6669-high_impact-news-local-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Local data-c-ssts=LOCAL></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Jackson trustees approve developer's site changes</h1><div class=gnt_ar_by>Patricia Faulhaber</div><div class=gnt_ar_pb>Suburbanite correspondent</div><div class=gnt_ar_dt aria-label="Published 10:11 a.m. ET May 26, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/ data-ss-t="Jackson trustees approve developer's site changes" data-ss-d="Approval came following public hearing where the developer talked discussed the housing plan"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1010995929332131&href=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F&text=Jackson%20trustees%20approve%20developer's%20site%20changes&via=SuburbaniteGHO" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Jackson%20trustees%20approve%20developer's%20site%20changes%20-%20from%20The%20Suburbanite&body=Jackson%20trustees%20approve%20developer's%20site%20changes%0A%0AApproval%20came%20following%20public%20hearing%20where%20the%20developer%20talked%20discussed%20the%20housing%20plan%0A%0ACheck%20out%20this%20story%20on%20thesuburbanite.com%3A%20https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - How to safely use a portable generator"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;oh-canton-weekly-C6669&#34;,&#34;pn&#34;:&#34;The Suburbanite&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;tech/problemsolved&#34;,&#34;byline&#34;:&#34;ProblemSolved&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-05-24T19:00:12Z&#34;,&#34;credit&#34;:&#34;ProblemSolved, USA TODAY&#34;,&#34;duration&#34;:89000,&#34;headline&#34;:&#34;5 essential tips for generator safety&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/03956b05-028b-47f5-a1b1-cf0ceae5bdc3/37edafaf-c891-4b9e-9c68-f4a2e0770842/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=5240744001&#34;,&#34;id&#34;:&#34;5240744001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/05/24/USAT/1eaca58d-afb6-4ee6-ad60-97effec79c6a-PS-Generator.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-05-24T19:00:12Z&#34;,&#34;keywords&#34;:&#34;generators,Overall Positive,Tips and Tricks,Home and Garden,Electricity,Video Syndication - USAT&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/03956b05-028b-47f5-a1b1-cf0ceae5bdc3/37edafaf-c891-4b9e-9c68-f4a2e0770842/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/tech/problemsolved/2021/05/24/how-safely-use-portable-generator/5240744001/&#34;},&#34;promoBrief&#34;:&#34;Generators can be dangerous if used incorrectly. Here are 5 tips to keep you safe when using one.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-05-24T19:00:12Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;tech&#34;,&#34;subsection&#34;:&#34;problemsolved&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;4bb1cc0d-9109-4c0d-8049-b267dbe3baca&#34;,&#34;name&#34;:&#34;generators&#34;},{&#34;id&#34;:&#34;7095bb07-b172-434b-a4eb-8856263ad949&#34;,&#34;name&#34;:&#34;Overall Positive&#34;},{&#34;id&#34;:&#34;d8d5604f-bf5c-46e6-8d4b-e5bd35ff1a37&#34;,&#34;name&#34;:&#34;Tips and Tricks&#34;},{&#34;id&#34;:&#34;fa7ad2ce-da60-4ac0-ab5a-0c1afb1f2f15&#34;,&#34;name&#34;:&#34;Home and Garden&#34;},{&#34;id&#34;:&#34;bc97289f-1a18-4775-a6f1-939b42d2b904&#34;,&#34;name&#34;:&#34;Electricity&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;}],&#34;title&#34;:&#34;How to safely use a portable generator&#34;,&#34;url&#34;:&#34;/videos/tech/problemsolved/2021/05/24/how-safely-use-portable-generator/5240744001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/05/24/USAT/1eaca58d-afb6-4ee6-ad60-97effec79c6a-PS-Generator.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="How to safely use a portable generator" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><p class=gnt_ar_b_p>JACKSON TWP. – The Jackson Township Board of Trustees held a public hearing during the May 24 meeting for revisions to property located at the corner of Portage Street Northwest and Lutz Avenue Northwest.</p><p class=gnt_ar_b_p>After hearing from the housing developer, trustees approved the site plan. The developer discussed changes to the accesss to Lutz from Franklin Avenue, answered questions from nearby residents and said the development will fit in with the surrounding community.</p><h2 class=gnt_ar_b_h2>In other actions, trustees:</h2><p class=gnt_ar_b_p>• Swore in a full-time police Sgt. Jamin C. Sprowl and a full-time patrol officer Zachary H. VanVoorhis. Sprowl will receive an annual salary of $79,797, while VanVoorhis will make $28.76 per hour.</p><p class=gnt_ar_b_p>• Paid bills in the amount of $823,712.</p><p class=gnt_ar_b_p>• Adjusted the hourly rate of part-time patrol officers from $20 an hour  to $23 per hour, effective the first full pay period in June 2021.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-canton-weekly-C6669-native-article_link-news-local-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>• Accepted several donations to the police department including $50 from Roger Hayasi; $15 from Alexander Vedmedev and Nina Staborova; and $250 rom Strip Deleaware LLC for the Pride program.</p><p class=gnt_ar_b_p>• Approved booking agreements for  LaFlavor and Blue water Kings Band for the 2021 Community Celebration.</p><h2 class=gnt_ar_b_h2>Reminder</h2><p class=gnt_ar_b_p>The following Amphitheater events are scheduled: Food Truck Thursdays 11 a.m. to 7 p.m. through September 30; and the Summer Concert Series, June 12, Hard Day’s Night Beatles Tribute Band. Tickets are available at www.jacksonamphitheater.com.</p><p class=gnt_ar_b_p><strong>UP NEXT: </strong>Meets 5 p.m. June 8 at Jackson Township Town Hall.   </p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/ data-ss-t="Jackson trustees approve developer's site changes" data-ss-d="Approval came following public hearing where the developer talked discussed the housing plan"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1010995929332131&href=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F&text=Jackson%20trustees%20approve%20developer's%20site%20changes&via=SuburbaniteGHO" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Jackson%20trustees%20approve%20developer's%20site%20changes%20-%20from%20The%20Suburbanite&body=Jackson%20trustees%20approve%20developer's%20site%20changes%0A%0AApproval%20came%20following%20public%20hearing%20where%20the%20developer%20talked%20discussed%20the%20housing%20plan%0A%0ACheck%20out%20this%20story%20on%20thesuburbanite.com%3A%20https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-oh-canton-weekly-C6669-poster-news-local-3 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.thesuburbanite.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F&marketName=thesuburbanite&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-canton-weekly-C6669-poster_scroll-news-local-4 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-oh-canton-weekly-C6669-leaderboard_btf-news-local-5 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="The Suburbanite - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.thesuburbanite.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.thesuburbanite.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.publicnoticesohio.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.thesuburbanite.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.thesuburbanite.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.thesuburbanite.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.thesuburbanite.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.thesuburbanite.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/ohio/canton class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.thesuburbanite.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.thesuburbanite.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.thesuburbanite.com/subscriberguide class=gnt_ft_a data-t-l=:f|v|c|support:subscriber-guide>Subscriber Guide</a> <a href=https://account.thesuburbanite.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.thesuburbanite.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://cm.thesuburbanite.com/specialoffer class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.thesuburbanite.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/thesuburbanite/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://twitter.com/SuburbaniteGHO class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=https://user.thesuburbanite.com/user/enewspaper/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:e-edition>E-Edition</a> <a href=https://thesuburbanite.newsbank.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:archives>Archives</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/OhCan class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.billeriq.com/ebpp/GHM377/Login/Index class=gnt_ft_a data-t-l=:f|v|c|our-partners:pay-your-ad-bill>Pay Your Ad Bill</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.thesuburbanite.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z343c41a59.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.thesuburbanite.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.thesuburbanite.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.thesuburbanite.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.thesuburbanite.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.thesuburbanite.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.thesuburbanite.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.thesuburbanite.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.thesuburbanite.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.thesuburbanite.com/NSUB-GUP/user/logout/?return-url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.thesuburbanite.com/NSUB-GUP/authenticate?success-url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F&cancel-url=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.thesuburbanite.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.thesuburbanite.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><script type="gnt/tmpl" data-tmpl-key=vdscta><div class=gnt_em_vp_sbcta><a class=gnt_em_vp_sbcta_sb data-t-l=":d|d|auto subscribe|${t}" target=_blank rel=noopener href="https://subscribe.thesuburbanite.com/specialoffer?gps-source=IUXPLAYEROVERLAY&itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp&onSuccessRedirectURL=https%3A%2F%2Fwww.thesuburbanite.com%2Fstory%2Fnews%2Flocal%2F2021%2F05%2F26%2Fjackson-trustees-approve-developers-site-changes%2F7445579002%2F">Subscribe</a> <a class=gnt_em_vp_sbcta_dt data-t-l=":d|d|auto included|${t}" target=_blank rel=noopener href="https://cm.thesuburbanite.com/whats-included-subscribe?itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp">What's included?</a></div>|styles|.gnt_em_vp_sbcta{display:flex;flex-direction:column;text-align:center;position:absolute;top:25px;z-index:4;width:400px;height:225px;background:#000;color:#fff;font-family:'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;-webkit-user-select:none;user-select:none}.gnt_em_vp_sbcta::before{content:'Autoplay videos can be distracting. Make them go away.';order:-1;margin:38px 0 0;padding:0 55px;font-size:16px;line-height:20px;font-weight:700}.gnt_em_vp_sbcta::after{content:'Subscribers can turn off autoplay video - and more!';order:-1;margin:6px 0 12px;padding:0 88px;font-size:14px;line-height:16px}.gnt_em_vp_sbcta_sb{width:88px;height:30px;margin:0 156px 9px;border-radius:2px;background:#fff;color:#1665cf;font:700 14px/30px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;text-decoration:none;text-align:center}.gnt_em_vp_sbcta_sb:hover{color:#0a32a0}.gnt_em_vp_sbcta_dt{width:max-content;margin:0 auto;padding:0 2px;outline-offset:1px;color:#fff;font:12px/14px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_em_vp_sbcta_dt:hover{color:#e0e0e0}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3BL7aYUBmpaJr1ArlSgNVoirauyc.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>{"@context":"http://schema.org","@type":"NewsArticle","headline":"Jackson trustees approve developer's site changes","description":"Approval came following public hearing where the developer talked discussed the housing plan","url":"https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.thesuburbanite.com/story/news/local/2021/05/26/jackson-trustees-approve-developers-site-changes/7445579002/"},"datePublished":"2021-05-26T14:11:24Z","dateCreated":"2021-05-26T14:11:24Z","dateModified":"2021-05-26T14:11:24Z","articleSection":"news","publisher":{"@type":"Organization","name":"The Suburbanite","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/thesuburbanite/images/site-nav-logo@2x.png"}},"author":["Patricia Faulhaber"],"keywords":["access:metered","ssts:news:local","type:story","tag:Jackson Township, OH","tag:Overall Neutral","tag:Bills and Invoices","tag:Salaries and Wages","tag:Donations and Donating"],"isAccessibleForFree":false,"hasPart":{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".gnt_ar_b"},"isPartOf":{"@type":["CreativeWork","Product"],"name":"Suburbanite correspondent - Unlimited Digital Access","productID":"thesuburbanite.com:standard"},"metadata":"{\"id\":\"7445579002\",\"siteCode\":\"NSUB\",\"contentSourceCode\":\"NSUB\",\"ssts\":\"news:local\",\"type\":\"story\"}"}</script></body></html>